Basket notification not working for certain customers
Incident Report for iPaper
Postmortem

What happened:

While adding alternative shop icon support to the new product view we missed an optional property check in a single place in our codebase. This mistake caused the code responsible for showing the "product added to basket" notification to fail.

How we fixed it:

We added the necessary null property check.

What we are doing to prevent it from happening again:

We improved the code responsible for defining product properties to get warnings whenever we use an optional property.

Posted Apr 25, 2024 - 14:28 CEST

Resolved
Basket notifications are broken for certain customers.
Posted Apr 25, 2024 - 09:30 CEST