Display is not loading as intended
Incident Report for iPaper
Resolved
The issue has been resolved.
Posted Sep 27, 2023 - 11:13 CEST
Monitoring
We have managed to fix the issue and now monitoring
Posted Sep 27, 2023 - 10:35 CEST
Investigating
We are currently investigating
Posted Sep 27, 2023 - 10:10 CEST
This incident affected: Display.