No tracking of heatmap hotspots
Incident Report for iPaper
Postmortem

On Monday, April 3rd, 2023 08:16AM CET, we identified a challenge with how we log and store data for our heatmap hotspots and archive catalog clicks.

The challenge has been resolved – but unfortunately, it resulted in hotspot data for our heatmap and archive catalog clicks not being available for a period of 13 days.

This should not happen, and we are truly sorry for how this may affect you and your business’ ability to efficiently review your catalog campaign's efficacy. We fully understand the importance of accurate data and the impact it has on your business decisions.

As such, we are taking steps to prevent similar incidents from occurring in the future.

Rest assured that the integrity and stability of the iPaper platform remains our top priority.

We appreciate your understanding, and our team remains available to answer any additional questions you may have.

Please read on for more information about this Incident.

When did this occur?

Error was introduced on March 21st, 2023 at 10:10 AM

While working to optimize our time tracking accuracy, we introduced some code that caused our registration of heatmap hotspot data and archive catalog clicks to fail due to not being recognized as valid client input.

What statistics have been affected?

  • Hotspot interactions drawn on the heatmap
  • Archive catalog clicks

Heatmap will show views, time spent and link interactions for the period, as these are all handled in a different process.

What are we doing to prevent this from occurring again?

We will be improving our internal logging procedures to better catch cases like this where data is wrongfully flagged as invalid. We will also be looking into our internal processes to see what we could have done to catch this sooner.

Are the affected statistics from this period lost - or can they be restored?

Unfortunately, the above-mentioned statistic metrics are lost and cannot be restored.

Posted Apr 03, 2023 - 11:53 CEST

Resolved
We noticed that our statistics tracking for point clicks was not working properly, which affects our heatmap hotspots
Posted Apr 03, 2023 - 11:48 CEST
This incident affected: Admin.