Unable to issue branded domain SSL due to provider outage

Incident Report for iPaper

Resolved

Provider has resolved their issues and our SSL issuance has been resumed.
Posted Jul 03, 2026 - 09:03 CEST

Identified

Our SSL provider is having an outage which is affecting our ability to issue certificates for branded domains, to protect customer domains we have halted issuance and will monitor the situation and resume when we are able to. We appreciate for your patience.
Posted Jul 02, 2026 - 20:12 CEST
This incident affected: Flipbooks (SSL Processing Service).