Experiencing missing page images from CDN

Incident Report for iPaper

Resolved

We are no longer seeing any issues with missing images and closing this incident.
Posted Jul 03, 2026 - 09:06 CEST

Monitoring

A fix has been implemented and cache has been updated. We will continue to monitor to make sure we are seeing no more missing images.
Posted Jul 02, 2026 - 16:40 CEST

Identified

We have found the source of the issue, this is caching issue on our CDN rules, we are working with our provider for a fix.
Posted Jul 02, 2026 - 10:33 CEST

Investigating

We are currently experiencing issues with some images not loading sporadically from our CDN and we are investigating.
Posted Jul 02, 2026 - 10:04 CEST
This incident affected: Flipbooks (Viewer).