Sporadic slow page loads in horizon

Incident Report for iPaper

Resolved

Marking this as resolved as there has been no more slowdowns observed
Posted Jul 13, 2026 - 21:18 CEST

Monitoring

We have rolled out a fix for our caching servers and all requests are now resolving normally. We will continue to monitor and close this once we are satisfied.
Posted Jul 13, 2026 - 16:06 CEST

Investigating

We are seeing slow loading of pages across the horizon admin, we are investigating the issue
Posted Jul 13, 2026 - 15:13 CEST
This incident affected: Horizon (Admin).