SSL Service unable to create new certificates
Incident Report for iPaper
Resolved
We are now able to process SSL orders again.
We will keep monitoring, but all systems are working as expected and all orders are completing as normal.

Thank you for your patience and we apologize for the inconvenience this has caused 🙏
Posted May 17, 2022 - 14:22 CEST
Identified
We are seeing challenges with issuing new certificates for branded domains, we have identified the issue and are working on a solution.
Please note, this does not affect existing certificates for branded domains.

Thank you for your understanding and patience while we resolve this issue.
Posted May 12, 2022 - 22:37 CEST
This incident affected: Services (SSL Processing Service).