Double registration of products added to basket
Incident Report for iPaper
Postmortem

On Monday, April 3rd, 2023 09:04 AM CET, we identified a challenge with how we log and store the event when products are added to cart in a flipbook.

The challenge has now been resolved – but unfortunately, it resulted in double basket events being logged and stored for flipbooks for a period of 19 days.

We understand the gravity of the situation and apologize for any inconvenience this may cause you and your business in terms of reviewing your catalog campaign's efficacy. We value the accuracy of data and its significance on business decisions, and our team is working towards preventing such incidents from happening again in the future.

We appreciate your understanding, and our team remains available to answer any additional questions you may have.

Please read on for more information about this Incident.

When did this occur?

Error was introduced on March 15th, 2023 at 1:40 PM CET

Upon the internal release of our new JS API v3, an error was introduced to the code, that caused products added to the basket to be reported twice to our backend.Our logging was not capable of detecting this as a problem, since it is reasonable that a customer can add the same product multiple times.

What statistics have been affected?

Products added to basket

What are we doing to prevent this from occurring again?

We are investigating ways to check if an event is originating from the same user action to build in resilience for this type of mistake.

What about statistics and events from this period - are they lost or can you restore them?

Fortunately, almost all basket events can be recalculated and restored to reflect the actual amount of products added to cart.

Only events occurring on Mar 15, 2023 will remain inaccurate.

When will this be done?

Recalculations will be planned and deployed after the Easter Holidays.

Posted Apr 03, 2023 - 11:52 CEST

Resolved
We noticed discrepancies in our statistics tracking for products added to basket
Posted Apr 03, 2023 - 11:50 CEST
This incident affected: Admin.