Unable to process new SSL certificates
Incident Report for iPaper
Resolved
We have resolved issues with checking CAA for branded domains, and are back to creating issues as normal again.
We appreciate your patience and have added several measures to better prevent this in the future.
Posted Dec 04, 2023 - 16:04 CET
Investigating
We are currently experiencing a challenge processing new SSL certificates.
We are working with our provider to resolve this as quickly as possible.

Existing certificates are unaffected, and are valid until February 12, 2024.
Posted Nov 29, 2023 - 15:33 CET
This incident affected: Services (SSL Processing Service).