Degraded flipbooks performance

Incident Report for iPaper

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 18:34 CEST

Monitoring

We are no longer seeing any degraded performance but will continue to monitor
Posted Sep 02, 2026 - 18:17 CEST

Identified

We are seeing some degraded performance across flipbooks and we have identified the issue to be a networking issue, we are implementing a fix
Posted Sep 02, 2026 - 18:12 CEST
This incident affected: Flipbooks (Viewer, Admin, Backend API, Pop-ups).