Select accounts are experiencing inflated page views and time spent statistics.
Incident Report for iPaper
Postmortem

Let us start off by sincerely apologizing for the series of statistics-related incidents in the past days 💔

This should not happen, and we truly apologize for any negative impact these incidents may have on your business's ability to efficiently evaluate your catalog campaign's effectiveness.

We acknowledge the significance of precise data and how it can influence your business decisions.

Therefore, we are implementing measures to prevent such occurrences from happening again.

Please be assured that the iPaper platform's integrity and stability remain our top priority.
We aim to do – and be – better than this!

At this time, we hope for, and appreciate, your understanding.

If you have additional questions, our team is available to assist you in any way we can.

Please read on for more information about this Incident.

What happened?

While working to optimize our time tracking accuracy, we introduced an edge case that has negatively impacted a group of customers. In certain cases, the registration would end up counting more page views than it should have, resulting in inflated page views and time tracking.

When did this occur?

Error was introduced on March 21st, 2023 at 10:10 AM CET

Error was resolved on April 4th, 2023 at 01:32 AM CEST

See related incident here:
No tracking of heatmap hotspots

What statistics have been affected?

  • Page views
  • Avg. page views
  • Avg. time spent

Which accounts / flipbooks were impacted?

This challenge has not impacted every account/customer.

But – unfortunately, we have identified a group of customers which have been affected negatively.

These customers have experienced massively inflated page views and time spent on certain Flipbooks, often with more average page views than total pages in the Flipbook.

We will reach out to the identified accounts directly, with a list of the affected flipbooks and options to proceed.

What if I identify similar statistical anomalies in my flipbooks?

There is no great solution, as we are unable to restore the data.

We can offer one of two options:

  1. We do nothing
    Your data remains as-is, with inflated pageviews and time spent.
  2. We reset your PageViews and Avg. Time Spent to 0 (zero)
    Your data is reset - but only for the affected flipbooks, in the affected period.
    Data reset is permanent and cannot be undone.

Reach out to us, if you would like to have the data reset (option 2).

What are we doing to prevent this from occurring again?

This was due to a missed edge case in our handling of statistics, while we do our very best to verify code changes that go into our platform, we do make mistakes. With that said, we should have been able to catch this a lot faster, and we will be strengthening our ability to detect statistics anomalies, and look into ways we can potentially improve our ability to restore data in case of mistakes like this in the future.

Posted Apr 04, 2023 - 16:44 CEST

Resolved
The rollback has adjusted statistical tracking to its previous baseline, without further inflated page views.
While we consider this challenge resolved, there is some aftermath, as some customers have had their statistical data affected during this period.

Stay tuned for a full Post Mortem, with additional information.
Posted Apr 04, 2023 - 16:31 CEST
Monitoring
We have performed a rollback on a set of changes made to our statistics tracking on March 21st.
We will continue to monitor and investigate the extent of customers impacted by this incident.
Posted Apr 04, 2023 - 01:44 CEST
Investigating
We are currently investigating the extent of the challenge.
This Incident will be continuously updated during the investigation.
Posted Apr 03, 2023 - 22:21 CEST
This incident affected: Admin.